Below are firmware updates for Meade mounts and the StarLock autoguider. Please read the installation instructions before attempting to update the firmware in your mount or StarLock unit.


StarLock Updates:
Firmware installation instructions (PDF)

May 23, 2013 - Firmware Update Version 1.1x
For use with all LX600 and LX850 firmware version 1.1g or newer.

May 23, 2013 - StarLock PEC Utility Version 1.0a
A new Starlock specific PEC Utility tool is now available. This version is only compatible with Starlock equipped telescopes and allows greater control over the Periodic Error Correction. After PEC training, use this tool to further refine your mounts PE curve. Instructions on using the Starlock PEC Tool can be downloaded here.



LX850 Firmware Updates:

May 23, 2013 - Version 1.1g 
An update to the LX850 firmware (version 1.1g) is now available through Meade's Autostar Updater 6.0 program. Version 1.1g uses an improved method of Starlock assisted PEC training allowing for a more accurate measurement of the worm figure.

To download, connect the LX850 to the computer, open the Updater program and select "Upgrade Autostar Software Now". Select "Check WWW for latest version" and install the new firmware. If you do not have Autostar Updater 6.0, you can download it here.

Note: Version 1.1g requires updated Starlock firmware (version 1.1x). To update your Starlock firmware to version 1.1x, download the firmware here and follow these instructions.



LX600 Firmware Updates (10" - 14"):

May 31, 2013 - Version 1.1g 
An update to the LX600 firmware (version 1.1g) is now available through Meade's Autostar Updater 6.0 program. Version 1.1g uses an improved method of Starlock assisted PEC training allowing for a more accurate measurement of the worm figure.

To download, connect the LX600 to the computer, open the Updater program and select "Upgrade Autostar Software Now". Select "Check WWW for latest version" and install the new firmware. If you do not have Autostar Updater 6.0, you can download it here.

Note: Version 1.1g requires updated Starlock firmware (version 1.1x). To update your Starlock firmware to version 1.1x, download the firmware here and follow these instructions.